PHP Warning: Declaration of … should be compatible with …..

Dieser Fehler ist typisch unter PHP7, weil es strengere Funktionsdefinitionen verlangt, als PHP5. Man hat zwei Möglichkeiten:

  1. Man unterdrückt die Meldungen, indem man im Install Tool PHP so einstellt, dass Warnungen unterdrückt werden
  2. Auf PHP 5.6 wechseln

Sven Wappler

Webentwickler, Programmierer, TYPO3 Experte

Das könnte Dich auch interessieren …

5 Antworten

  1. Andreas Kinzler sagt:

    Mit dem Development-Stand von flux von https://github.com/FluidTYPO3/flux geht alles wieder prima

  2. Georg Ringer sagt:

    Besser wäre den Fehler zu fixen, weil der Fix läuft auch unter PHP 5.6

    • Sven Wappler sagt:

      Da bin ich bei dir. Saubereres Programmieren sollte immer das Ziel sein. Der Eintrag wurde damals aus der Not geschrieben, als ich mich noch nicht detailliert mit dem Problem auseinander gesetzt hatte. Ein Update folgt 😉

  3. Andy sagt:

    Habe in meiner WordPress Installation jetzt die Fehlermeldungen deaktiviert, da der Fehler sonst immer im Header angezeigt wurde.
    Habe ein Plugin, bei dem dieser Fehler auftaucht. Es funktioniert alles, allerdings wäre schön den Fehler zu eliminieren, hoffe, das passiert mit einem Update des Plugins.
    Trotzdem schon mal Danke für den Hinweis.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.