Es wird nur Schrift ohne CSS ausgegeben

Dies ist ein Indiz dafür, dass die Dateirechte nicht passen. PHP schreibt Daten auf die Festplatte, die dann der Webserver nicht mehr lesen kann. Dies kann man beheben, indem Sie im Backend unter „Einstellungen“ (Hauptmenü) in „Configure Installation-Wide Options“ gehen und dort die Optionen
[SYS][fileCreateMask]
[SYS][folderCreateMask]
anpassen. Welche die richtigen Einstellungen für Ihren Server sind, kann pauschal leider nicht gesagt werden, weil Hoster verschiedene Konfigurationen verwenden.
Sollten Sie Hilfe bei der Einrichtung benötigen, so können Sie gerne eine Anfrage an mich senden.

Mögliche Einstellungen je nach Hoster

all-inkl
fileCreateMask: 755
folderCreateMask: 755

Ionos
fileCreateMask: 755
folderCreateMask: 755

Sven Wappler

Webentwickler, Programmierer, TYPO3 Experte

Das könnte dich auch interessieren …

2 Antworten

  1. Klaus Tembrink sagt:

    Hallo Herr Wappler,
    ich habe eine laufende Installation (Typo3 9.5.5) mit T3Bootstarp 4 bei einem Hoster erfolgreich laufen. Nun wollen wir die Inhalte in eine neuere Version überführen. Dazu habe ich, nach ihrer Anleitung und wie gewohnt, die neuste Version ihres Templates installiert. Dabei bekomme ich genau das beschriebene Phänomen. Der Text ist da, CSS fehlt!?
    Ich habe mir die Einstellungen von [SYS][fileCreateMask] [SYS][folderCreateMask] der laufenden Installation angesehen. Diese sind beide gleich. Dennoch fehlt das CSS? Ich habe daraufhin versucht bei einem anderen Hoster T3Bootstrap zu installieren, auch dort das gleiche Ergebnis!?! Hätten Sie noch eine andere Idee warum CSS fehlen könnte?

    • Sven Wappler sagt:

      Hallo Herr Tembrink,
      Sie müssen sicherstellen, dass die bereits (durch die Dateiübertragung auf den Server) angelegten Ordner auch die richtigen Rechte besitzen. Zur Not die Ordner /typo3temp/assets und alle _processed_ Ordner löschen und über das Install Tool neu anlegen lassen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.